読者です 読者をやめる 読者になる 読者になる

恵比寿ではたらくSEの適当なブログ

日々の出来事をたまに書きます

プログラミング

Ruby 1.8.7と1.9.3が共存した環境でrake db:migrateがエラー

Ruby 1.8.7と1.9.3が混在した状況で「rake db:migrate」というコマンドを実行をしたらエラーになった。> rake db:migraterake aborted!can't activate rake (= 0.9.2, runtime) for , already activated rake-10.0.2 for /Rakefile:8(See full trace by runn…

NetBeans6.9.1+Ruby1.9.3+Rails3.2.8でデバッガーを動かす

Railsのバージョンアップをしたら、開発環境(NetBeans)のデバッガが動かなくなってしまった・・ま、当然といえば当然なんだけど。いろいろ調べてやっと動いたのでメモしておこう。Windows7Netbeans:6.9.1Ruby:1.9.3Rails:3.2.81. 下記のサイトからinecach…

Windows7でRailis環境構築 Ruby1.9.3+Rails3.2.8+MySQL

開発環境のRailsのバージョンを2.3.11から3.2.8へバージョンアップ。bundle installしたら、MySQLコネクターもバージョンアップする必要があるんだとか。============================================================= You've installed the binary versio…

An error occurred while installing libv8 (3.11.8.4)

linuxにbundle installを実行したらこんなエラーがでたGem files will remain installed in C:/ruby193/lib/ruby/gems/1.9.1/gems/libv8-3.11.8.4 for inspection.Results logged to C:/ruby193/lib/ruby/gems/1.9.1/gems/libv8-3.11.8.4/ext/libv8/gem_make…

bundle installでAn error occurred while installing json (1.7.5)というエラー

Rails2.3.11からRails3.2.5にバージョンアップ。Rails3から必要なgemはbundlerを使ってインストール。bundle install コマンドを実行!!すると、こんなエラーが発生・・Please update your PATH to include build tools or download the DevKitfrom 'http:/…